Building gcc with gmp source is failing with "Can't find gmp headers" (Centos 6.5)

Dave Gittins dave.gittins@gmail.com
Mon Apr 14 07:12:00 GMT 2014


On Mon, Apr 14, 2014 at 4:11 PM, Marc Glisse <marc.glisse@inria.fr> wrote:
> On Mon, 14 Apr 2014, Dave Gittins wrote:
>
>> I need to build gcc 4.4.0 (for various reasons beyond my control!) on
>> my Centos 6.5 box. I want the resulting binaries to be usable by
>> others who may not have the same external packages installed. So I am
>> attempting to follow the instructions that suggest placing the source
>> distributions for GMP/MPFR/MPC/ISL/CLooG in subdirectories of the main
>> source directory.
>
>
> Note that isl/cloog (hmm, wasn't gcc using ppl instead of isl at the time?
> Where did you find those requirements?) are optional, so easiest is to avoid
> them. For a while (I hope it was fixed since but I haven't checked), it
> worked to let gcc build gmp/mpfr/mpc, it worked to let gcc build ppl (or
> isl) and cloog if you already had gmp/mpfr/mpc in the system, but it
> couldn't build all 5 because it didn't pass suitable options to the last
> ones to let them use the first 3, and that seems to be the issue you are
> hitting.
>
> Btw, are you sure you can't use at least gcc-4.4.x for some larger value of
> x?
>
> --
> Marc Glisse

Interesting. I will be building later versions as well (and making a
transition to 4.8.X as soon as I can)... but as a first step I have to
work with 4.4.0 unfortunately.

I got the requirements from
http://gcc.gnu.org/install/prerequisites.html. Perhaps it is not true
for versions as old as 4.4.0?

Dropping cloog might be the pragmatic solution for now as we can live
without any of the graphite loop optimisation stuff. I can bring it in
when I move on to later versions.

D



More information about the Gcc-help mailing list