libgcc

Hendrik Greving hendrik.greving.intel@gmail.com
Thu Sep 5 16:40:00 GMT 2013


Hi, when compiling HelloWorld with a newly ported 4.8.1 with own
backend, using newlib-2.0.0 and binutils-2.23.2, I am getting a bunch
of missing symbols, e.g.

/my/bin/path/lib/gcc/<mytarget>/4.8.1/../../../../<mytarget>/lib/libc.a(lib_a-vfprintf.o):
In function `_vfprintf_r':
/my/path/to/obj/fsf-4.8.1/<mytarget>/newlib/libc/stdio/../../../../../../../src/tools/fsf-4.8.1/newlib/libc/stdio/vfprintf.c:1086:
undefined reference to `__ltdf2'
/my/path/to/obj/fsf-4.8.1/<mytarget>/newlib/libc/stdio/../../../../../../../src/tools/fsf-4.8.1/newlib/libc/stdio/vfprintf.c:1558:
undefined reference to `__eqdf2'
/my/path/to/obj/fsf-4.8.1/<mytarget>/newlib/libc/stdio/../../../../../../../src/tools/fsf-4.8.1/newlib/libc/stdio/vfprintf.c:1605:
undefined reference to `__nedf2'
/tmp/localdisk/hgreving/mnr-uarch-cms_current/install/bin_4_8_1/lib/gcc/<mytarget>/4.8.1/../../../../<mytarget>/lib/libc.a(lib_a-vfprintf.o):
In function `cvt':
/my/path/to/obj/fsf-4.8.1/<mytarget>/newlib/libc/stdio/../../../../../../../src/tools/fsf-4.8.1/newlib/libc/stdio/vfprintf.c:1734:
undefined reference to `__nedf2'

and more. I think this stuff belongs to libgcc, but the symbols are
not there. E.g.

nm ./fsf-4.8.1/<mytarget>/libgcc/libgcc.a | grep ltdf2
         U __ltdf2
         U __ltdf2

Am I doing something wrong when configuring libgcc maybe?

Thanks
Regards,
Hendrik Greving



More information about the Gcc-help mailing list