4.7.2 install fails on Raspberry Pi

Kai Ruottu kai.ruottu@wippies.com
Fri Mar 22 10:52:00 GMT 2013

7.3.2013 9:13, Bela Markus kirjoitti:
> After spending few days no success to install it. If ARM CPU type and 
> floating not specified either in C/CXX flags or as config options 
> libgcc compile etst with xgcc fails due to unsupported processor 
> instructions. It's clear, can be accepted. Specifying proper options 
> xgcc test fail due to mismatch of cpu specifications. It is a 4.7.2 
> specific bug as same build script installs 4.6.3 properly.

I tried a cross GCC for 'arm-linux-gnueabihf'  (a stripped name for the 
from the FSF gcc-4.6.3 sources and found out that the '-gnueabihf' etc. 
weren't understood in the
pristine FSF sources but three patchfiles (.diff) were required!

So, expecting also the gcc-4.7.2 sources to require extra patches for 
the '-eabihf' case would be wise...

When researching via net how others had built their Raspberry Pi 
targeted toolchains, I saw really
weird "you must reinvent the wheel again" instructions like rebuilding 
the eglibc in Raspberry Wheezy,
the Linux-distro for Raspberry Pi I used as the "target".  The SD-card 
install had the prebuilt eglibc,
ok, a little customized Debian-like one keeping things in 
'arm-linux-gnueabihf' subdirectories instead of
the standard places, but in any case it was prebuilt and required only 
copying it onto the cross host...
For instance :
The info for finding the patches however was there :
pointing to the :

Maybe I will try gcc-4.7.2 next, actually I already tried the pristine 
FSF sources already at the same time
with the gcc-4.6.3 ones and they gave just the same error :
"sorry, unimplemented: -mfloat-abi=hard and VFP"
when configuring libgcc...

More information about the Gcc-help mailing list