configure: WARNING: unrecognized options

Roberto Nunnari roberto.nunnari@supsi.ch
Tue Jul 9 15:23:00 GMT 2013


Paul Smith wrote:
> On Tue, 2013-07-09 at 16:31 +0200, Roberto Nunnari wrote:
>> // configure gcc
>> # mkdir gcc-build && cd gcc-build
>> # ../gcc-4.8.1/gcc/configure --prefix=/opt/gcc481 
>> --enable-languages=c,fortran --with-gmp=/opt/gmp --with-isl=/opt/isl 
>> --with-cloog=/opt/cloog
>> ...
>> configure: WARNING: unrecognized options: --with-gmp, --with-isl, 
>> --with-cloog
> 
> Your most immediate problem is that you're running
> gcc-4.8.1/gcc/configure when you should be running gcc-4.8.1/configure.
>           ^^^
>    
> The configure script inside the gcc subdirectory ONLY configures the
> compiler itself, it doesn't know about all the other extra stuff.
> That's why it doesn't recognize those extra configure flags.

ah.. I will try that right away.. I read somewhere that you must use 
gcc-4.8.1/configure if you got gcc via svn, and gcc-4.8.1/gcc/configure 
otherwise..



More information about the Gcc-help mailing list