Compiling gcc-4.8.1 against glibc-2.17 and linux-3.10.1

Ian Lance Taylor iant@google.com
Mon Jul 22 06:45:00 GMT 2013


On Sun, Jul 21, 2013 at 12:34 PM, Mischa Baars <mjbaars1977@gmail.com> wrote:
>
> While executing the following commands:
>
> tar xvjpf ./linux-3.10.1.tar.bz2 && cd ./linux-3.10.1 && make
> O=/root/develop headers_install
> tar xvjpf ./glibc-2.17.tar.bz2 && mkdir ./glibc-build && cd ./glibc-build &&
> ../glibc-2.17/configure --prefix=/root/develop && make && make install
> tar xvjpf ./gcc-4.8.1.tar.bz2 && mkdir ./gcc-build && cd ./gcc-build &&
> ../gcc-4.8.1/configure --prefix=/root/develop --with-sysroot=/root/develop
> --enable-languages="c,c++" && make
>
> I get compilation errors as shown in the attachment while trying to compile
> gcc-4.8.1.

Building a new version of gcc that uses a new version of glibc on
GNU/Linux is an art form.  I wish it weren't so, but it is.  I suggest
looking at the recipes at linuxfromscratch.org.

Ian



More information about the Gcc-help mailing list