maybe a bug in gcc 4.8 triggered with libdrm

Andreas Radke andyrtr@googlemail.com
Sat Jul 13 18:03:00 GMT 2013


I'm faced with graphic glitches, desktop hanging and finally random
Xorg crashes when libdrm is built with gcc 4.8 (latest final
4.8.1 release). dmesg gives random graphics related error messages
using a nvidia card here with nouveau.

The system runs well when I compile latest libdrm with gcc 4.7.3 and
also with clang (llvm 3.3). This reminds me a similar issue I'm faced
with kernel xfs file system when build with gcc 4.8 that I have
reported under: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57436 .

Our ArchLinux default flags are:
CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector
--param=ssp-buffer-size=4" 

I've tried new gcc 4.8 and replacing -O2 with -O1, with -O0 and with
-fno-aggressive-loop-optimizations with the same result of a broken X
desktop.

With libdrm on my desktop I can test everything you want to track this
issue down. Right now I can't do this with my kernel issue.

Please give me suggestions how to find out what is broken with gcc 4.8.
So far I've built it also with -save-temps to keep .s files but I'm not
sure what to compare.

-Andy
ArchLinux



More information about the Gcc-help mailing list