What version of GCC started supporting .arch_extension sec

William Roberts bill.c.roberts@gmail.com
Thu Jul 26 00:02:00 GMT 2012


Yes it is in the assembler I should have mentioned it, is their a
separate mailing list for that?

I need a way to conditionally add ".arch_extension sec" based on some
environment preprocessor flag.

Currently I am currently doing something like this:
#if __GNUC__ >= 4 && __GNUC_MINOR__ >= 6
        .arch_extension sec
#endif

Which I know isn't completely what I want.

Thanks.


On Wed, Jul 25, 2012 at 4:31 PM, Ian Lance Taylor <iant@google.com> wrote:
> On Wed, Jul 25, 2012 at 2:35 PM, William Roberts
> <bill.c.roberts@gmail.com> wrote:
>> I am trying to track down what version of GCC started supporting
>> .arch_extension sec.
>>
>> I know 4.4.0 did not and 4.6 does.
>
> The only .arch_extension I know of is not part of GCC at all.  It is a
> pseudoop supported by the GNU ARM assembler.  It first appeared in GNU
> binutils 2.21.
>
> Ian



-- 
Respectfully,

William C Roberts



More information about the Gcc-help mailing list