Problems compiling the GCC 4.3.5

kevin diggs diggskevin38@gmail.com
Thu Jan 27 23:03:00 GMT 2011


>
> I still get the same error message
> checking whether ln -s works... yes
> checking for i386-apple-darwin10.6.0-gcc...
> /Users/toom/Downloads/gcc-4.3.5/obj-gcc-4.3.5/./gcc/xgcc
> -B/Users/toom/Downloads/gcc-4.3.5/obj-gcc-4.3.5/./gcc/
> -B/Users/toom/gcc4.3.5//i386-apple-darwin10.6.0/bin/
> -B/Users/toom/gcc4.3.5//i386-apple-darwin10.6.0/lib/ -isystem
> /Users/toom/gcc4.3.5//i386-apple-darwin10.6.0/include -isystem
> /Users/toom/gcc4.3.5//i386-apple-darwin10.6.0/sys-include
> checking for suffix of object files... configure: error: cannot compute
> suffix of object files: cannot compile
> See `config.log' for more details.
> make[2]: *** [configure-stage1-target-libgcc] Error 1
> make[1]: *** [stage1-bubble] Error 2
> make: *** [bootstrap] Error 2
>
Is this fail pretty early? Lets see what is in config.log. That should
contain clues as to why it "cannot compile". It looks like it can't
find all the pieces it needs to run test programs. Some of these
configure tests actually create and compile test programs to check for
things. The "cannot compile" message seems to indicate that there is a
problem even getting things to build. I think I have seen this when I
have had typos in compile flags. Like passing something like
"-march=pentium3" in CFLAGS environment variable to a powerpc
compiler. The compiler will choke on this because it is not valid
command line option for powerpc.

Maybe we backtrack a little. Is this a powerpc or intel mac?

kevin



More information about the Gcc-help mailing list