Error when compiling gcc-4.4.6 in linux

Kai Ruottu kai.ruottu@wippies.com
Tue Dec 20 23:46:00 GMT 2011


20.12.2011 23:15, kevin diggs kirjoitti:

> On Tue, Dec 20, 2011 at 1:49 PM, Watson, Christa
> <CWatson@memory.ucsf.edu>  wrote:
>> Hello,
>> I have tried to compile gcc-4.4.6 on my computer with a scientific linux OS.
 >> I successfully compiled and installed gmp-5.0.2, mpc-0.9, and mpfr-31.0.
 >> However when I run the make command for the gcc I get this error:
>> checking for suffix of object files... configure: error:
 >> in `/usr/local/contrib/build/x86_64-unknown-linux-gnu/libgcc':
>> configure: error: cannot compute suffix of object files: cannot compile
>
> If you built dynamic versions of the prereqs then you need to make
> sure the dynamic linker (ld.so or whatever it is called) can find them
> at run time. See the man page for ldconfig. Maybe you need to edit
> /etc/ld.so.conf?
>
> I've always found this "feature" confusing, too (to?).

What really is confusing in them? That people don't know what gmp, mpfr
and mpc are, or don't expect their system yet having them? Let's see...

The more than one year old Fedora 14 Linux distro for x86_64 has in
'/linux/releases/14/Fedora/x86_64/os/Packages' the following install
packages :

gmp-4.3.1-7.fc14.x86_64.rpm
mpfr-2.4.2-1.fc13.x86_64.rpm

No 'mpc' though, so one must build it and install it in the Fedora
14 case... If so, where a sane person would install it - its shared
libraries - when it is missing from one's base system? Somewhere where
all executables can find its shared libraries? Or somewhere where only
some defined executables can find its shared libraries?

The big question here is whether a layman should understand these
"what the shared libraries (DLLs in Windoze world) are and where
they should be" - issues when creating executables, here GCC binaries
(xgcc, cc1*, collect2,...) which will use shared libraries at runtime...



More information about the Gcc-help mailing list