aix cross(?)compiler

Kai Ruottu kai.ruottu@wippies.com
Wed Dec 14 17:10:00 GMT 2011


14.12.2011 13:42, Jędrzej Dudkiewicz kirjoitti:

> Well, it must :), otherwise building it is quite probably impossible,
>   as it seems that GNU binutils do not fully support AIX - but I can't
>   say for sure, as I were unable to find a definite list of supported
>   systems. I tried building using GNU binutils, but 'as' refused to
>   compile source code, claiming that it does not know about instruction
>   fmul, if my memory serves well.

Hard to say what the GNU binutils really support or not but trying them
is always possible. So I tried the binutils-2.20.51 :

[root@localhost build]# rs6000-ibm-aix4.3-as --version
GNU assembler (Linux/GNU Binutils) 2.20.51.0.8.20100412
Copyright 2010 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or later.
This program has absolutely no warranty.
This assembler was configured for a target of `rs6000-ibm-aix4.3'.

and then gcc-4.6.2.  Of course it crashed during the libgcc build :

/home/src/gcc-4.6.2/build/./gcc/xgcc -B/home/src/gcc-4.6.2/build/./gcc/ 
-B/usr/local/rs6000-ibm-aix4.3/bin/ -B/usr/local/rs6000-ibm-aix4.3/lib/ 
-isystem /usr/local/rs6000-ibm-aix4.3/include -isystem 
/usr/local/rs6000-ibm-aix4.3/sys-include    -g -Os -pthread -O2  -g -Os 
-DIN_GCC -DCROSS_DIRECTORY_STRUCTURE  -W -Wall -Wwrite-strings 
-Wcast-qual -Wstrict-prototypes -Wmissing-prototypes 
-Wold-style-definition  -isystem ./include  -mlong-double-128 -g 
-DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED 
-fno-stack-protector -Dinhibit_libc  -I. -I. -I../../.././gcc 
-I../../../../libgcc -I../../../../libgcc/. -I../../../../libgcc/../gcc 
-I../../../../libgcc/../include  -DHAVE_CC_TLS -DUSE_EMUTLS -o 
unwind-dw2.o -MT unwind-dw2.o -MD -MP -MF unwind-dw2.dep -fexceptions -c 
../../../../libgcc/../gcc/unwind-dw2.c
In file included from ../../../../libgcc/../gcc/gthr-aix.h:30:0,
                  from ../../.././gcc/gthr-default.h:1,
                  from ../../../../libgcc/../gcc/gthr.h:162,
                  from ../../../../libgcc/../gcc/unwind-dw2.c:37:
../../../../libgcc/../gcc/gthr-posix.h:44:1: error: unknown type name 
'pthread_t'
../../../../libgcc/../gcc/gthr-posix.h:45:1: error: unknown type name 
'pthread_key_t'
../../../../libgcc/../gcc/gthr-posix.h:46:1: error: unknown type name 
'pthread_once_t'
../../../../libgcc/../gcc/gthr-posix.h:47:1: error: unknown type name 
'pthread_mutex_t'
../../../../libgcc/../gcc/gthr-posix.h:48:1: error: unknown type name 
'pthread_mutex_t'
../../../../libgcc/../gcc/gthr-posix.h:49:1: error: unknown type name 
'pthread_cond_t'

when I hadn't those AIX 4.3 target headers :-( My configure options
can be seen in the following :

[root@localhost build]# gcc/xgcc -v
Using built-in specs.
COLLECT_GCC=gcc/xgcc
Target: rs6000-ibm-aix4.3
Configured with: ../configure --build=i686-linux-gnu 
--host=i686-linux-gnu --target=rs6000-ibm-aix4.3 --with-gnu-as 
--with-gnu-ld --enable-languages=c,c++ --disable-threads --disable-nls
Thread model: aix
gcc version 4.6.2 (GCC)

The '--disable-threads' didn't seem to have any influence!

The 'gmp', 'mpfr' and 'mpc' sources were built with the gcc-4.6.2
sources...

Are the AIX 4.3 etc C-libraries freely available somewhere nowadays?
Years ago I tried to find them but then IBM hadn't put them freely
available like SGI with Irix stuff and Sun with Solaris2 stuff :-(



More information about the Gcc-help mailing list