MIPS 32-bit ABI stack pointer

Ian Lance Taylor iant@google.com
Thu Nov 11 06:09:00 GMT 2010


Mason <mpeg.blue@free.fr> writes:

> I got errors for o64, n32, 64
> foo.c:1: error: '-march=mips32r2' is not compatible with the selected ABI
> foo.c:1: error: '-march=mips32r2' is not compatible with the selected ABI
> foo.c:1: error: '-march=mips32r2' is not compatible with the selected ABI

Those ABIs require running the processor in 64-bit mode.  This is true
even for n32, because it requires the 64-bit floating point registers.

> Does this mean all I need to do is compile everything with -mabi=eabi ?
> And it will all auto-magically work?  :-)

It depends on what your other compiler does.

Ian



More information about the Gcc-help mailing list