[GCC front end] trying to install sample_fe but fail in make

charfi asma charfiasma@yahoo.fr
Mon Jun 7 16:11:00 GMT 2010





----- Message d'origine ----
De : Andi Hellmund <mail@andihellmund.com>
À : charfi asma <charfiasma@yahoo.fr>
Cc : mail@andihellmund.com; gcc-help@gcc.gnu.org
Envoyé le : Lun 7 juin 2010, 15h 34min 37s
Objet : Re: Re : [GCC front end] trying to install sample_fe but fail in  make


Hello,


okay, that's not good. Usually, when working on a front-end, I disable the
bootstrapping (using --disable-bootstrap) option to accelerate the build
to get the new front-end as fast as possible. Even though the Make-lang.in
of sample_fe isn't complete, it should be able to handle the bootstrap
case

Ok I will try to make without bootstrap (I used make bootstrap cause I red in http://gcc.gnu.org/install/build.html in building a native compiler section that it is recommended to enable bootstrap because the compiler will be tested more completely and could also have a better performance.


If you however insist on using 4.1.0, I could prepare sample_fe for this
version?

I used this version because I have a mandriva 2006. I tried to install gcc4.4.2 but when configuring it, it generates errors concerning GMP and MPFR (require 4.1+ of GMP and 2.3.2+ of MPFR)
I installed the MPFR2.4.2 without pb and a 4.1.3.2 of GMP (an rpm: libgmp and gmp-devel) but gcc4.4.2 requires GMP4.2
I tried to install GMP4.2.2 (rpm) I  get this errors:
dependences required:
libc.so.6 (GLIBC_2.4)
rtld( GNU_HASH)

When I install GMP 4.1.3.2 I did not get a pb. (that's why I tried to install an old version of gcc that did not require GMP 4.2)

I tried to configure with --with-gmp but I did not find where the gmp is installed
whereis gmp gives /usr/include/gmp.h 
which gmp returns no gmp in (/usr/bin: /sbin: /usr/sbin: /usr/local/bin......)

what do you suggest? I am not an expert in handling linux distribution and install directories :(

thank you very much for your help

Asma






More information about the Gcc-help mailing list