__sync_fetch_and_add and gcc-4.4.1

Andrew Haley aph@redhat.com
Thu Feb 4 12:18:00 GMT 2010


On 03/02/10 19:53, Vincent Richomme wrote:

> When trying to compile opencflite I get the following error :
> 
> configure: checking for compiler atomic built-ins
> checking whether the target supports __sync_fetch_and_add... no
> configure: error: Support for __sync_fetch_and_add is required.
> 
> Dont' know what it means and how to fix it.
> Any sugestions ?

__sync_fetch_and_add is a built-in gcc function.  It's not working
for some reason.

The way to fix it depends on the machine, the OS, and the version of
gcc you're using.

Andrew.



More information about the Gcc-help mailing list