optimization options not working

rohitgeek rohit23taneja@gmail.com
Fri Feb 19 19:07:00 GMT 2010



hi 

this is what i am doing :-

1. Created the machine description files
2. Build my target (successful)
3. Compile 
       Now this step works correctly i.e. generate correct assembly if i do
not put any optimization option.
   
     command : ----    ./target-gcc -S test.c     -> works
                              ./target-gcc -O1/2/3 -S test.c    -> no
assembly corresponding to the variable assignment and all other operations
i.e. it generates only prologue and epilogue(if i am correct for later
part).

Give me some insight into working of peephole optimizations, how do i start
doing that.

Rohit




 

Andrew Haley wrote:
> 
> On 02/18/2010 12:03 PM, rohitgeek wrote:
> 
>> I am a newbie in compilers, recently came across a problem that when i
>> try
>> to use optimization options( -O_   ) during compilation , i do not get
>> the
>> asembly for the processor that i am porting gcc to. Is there a simple
>> thing
>> i am missing somewhere? 
> 
> Probably.  Tell us exactly what you did, with full details.
> 
> http://catb.org/~esr/faqs/smart-questions.html
> 
>> Secondly, are there some macros i need to define in regard with
>> optimization.
> 
> No.
> 
> Andrew.
> 
> 

-- 
View this message in context: http://old.nabble.com/optimization-options-not-working-tp27637400p27650186.html
Sent from the gcc - Help mailing list archive at Nabble.com.



More information about the Gcc-help mailing list