Unable to get a plugin working

Hristina Fidanoska fidanconscious@googlemail.com
Sat Feb 13 01:26:00 GMT 2010


Hello,

For the use of a plugin in our project, I have installed the latest GCC 
version (gcc-4.5-20100211)
and I configured it using the options:

  --enable-languages=c,c++ --enable-plugin --prefix=/opt/<plugin>

Now after compiling the plugin, I get an error when linking:

cc1plus: error: Cannot load plugin ../libimo/libimo.so

/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by ../libimo/libimo.so)

make: *** [default] Error 1


Browsing threads for similar problems, I read that a quick fix would be 
to set the LD_LIBRARY_PATH to point to the directory where libstdc++ is 
located,  in my case

LD_LIBRARY_PATH=/usr/lib/libstdc++.so.6.0.13

LD_LIBRARY_PATH=/usr/lib/libstdc++.so.6



However, this did not solve the problem.
Any suggestions?


Best regards,
Tina





More information about the Gcc-help mailing list