How can I avoid the dreaded "cannot compute suffix of object files"?

Dr. David Kirkby david.kirkby@onetel.net
Thu Feb 11 18:48:00 GMT 2010


Dennis Clarke wrote:

> David, I never use LD_LIBRARY_PATH on Solaris unless someone has a taser
> pressed to my head. It is very bad practice.

I can understand that.

> Just try --with-gmp=/opt/csw --with-mpfr=/opt/csw or whereever you have
> it. Do not put "lib" there.

I had tried that before, but it did not work.

> Also, set your LD_OPTIONS correctly and use the Sun linker and you should
> be okay.



This has just failed for me. I used a shell of /bin/bash, and also set

SHELL=/bin/bash

since some have said in the past that is necessary.

# env | grep LD

OLDPWD=/patches/builds/mpfr-2.4.2
LD_OPTIONS=-R/usr/local/gcc-4.3.4/lib -L/usr/local/gcc-4.3.4/lib

# ../gcc-4.4.3/configure  --prefix=/usr/local/gcc-4.4.3 
--with-mpfr=/usr/local/gcc-4.4.3 --with-build-time-tools=/usr/ccs/bin 
--with-gmp=/usr/local/gcc-4.4.3  --enable-languages=c,c++,fortran

Can you tell me

1) How do you configure GMP - do you use a 32 or 64-bit ABI? What options are 
used to GMP's configure script.

2) Do you build GMP twice - one as a 32-bit ABI, and a second as a 64-bit ABI, 
and in the latter case putting the libraries in /opt/csw/lib/sparcv9 ?

2) How do you configure MPFR - what options are used to for MPRF's configure 
script? Again any specific issues about getting 32-bit libraries in /opt/csw/lib 
and 64-bit libraries in /opt/csw/lib/sparcv9 ?

3) What could be wrong with my setting of LD_OPTIONS of:

LD_OPTIONS=-R/usr/local/gcc-4.3.4/lib -L/usr/local/gcc-4.3.4/lib

I've also tried just the -R bit, without the -L bit.

It's obvious to me you can do this, but I can't get the ****** thing to work for 
me!

dave



More information about the Gcc-help mailing list