Help building gcc

afkoeppel afk2s@virginia.edu
Tue Feb 9 20:01:00 GMT 2010


Hello,

I am brand new to linux/unix and I am trying to install a program that
requires gfortran.  My understanding is that gfortran is part of gcc, and
that I therefore need to install gcc to run it.  I have been having some
problems accomplishing this, however.  

I have downloaded the source, and (I think) installed all the prerequisite
programs.  The configure runs just fine, but when I try to build the
program, it runs for several minutes before giving the following error:

checking for x86_64-unknown-linux-gnu-gcc.../home/afkoeppel/objdir/.gcc/xgcc
-B/home/afkoeppel/objdir/./gcc
-B/home/afkoeppel/gcc-install//x86_64unknown-linux-gnu/lib/
-B/home/afkoeppel/gcc-install//x86_64unknown-linux-gnu/include -isystem
/home/afkoeppel/gcc-install//x86_64unknown-linux-gnu/sys-include
checking for suffix of object files... configure error: in
'/home/afkoeppel/objdir/x86_64unknown-linux-gnu/libgcc':
configure: error: cannot compute suffix of object files: cannot compile
see 'config.log' for more details.
make [2]: ***[configure-stage1-target-libgcc] Error 1
make [2]: Leaving directory '/home/afkoeppel/objdir'
make [1] ***[-stage1-bubble] Error 2
make [1]: Leaving directory '/home/afkoeppel/objdir'
make; *** [all] Error 2

I followed the suggestion to look in config.log, but my comprehension is too
limited at this point to make any sense of what I'm finding there. 
Searching for the error here I found the suggestion that adding gmp and mpfr
to the LD_LIBRARY_PATH might solve the problem.  
http://old.nabble.com/-Bug-bootstrap-35577---New:-configure:-error:-cannot-compute-suffix-of-object-files-td16038190.html
http://old.nabble.com/-Bug-bootstrap-35577---New:-configure:-error:-cannot-compute-suffix-of-object-files-td16038190.html

I tried this, but I'm not entirely sure if I've done it correctly, and I am
still getting the same error.  
I've attached my config.log file to this post, and I'm hoping someone will
be able to help me figure out what I've been doing wrong.  I apologize if
the error is something very basic, or very stupid, or covered thoroughly
here already and I just missed it.   
Thanks in advance for any help anyone can provide. 

http://old.nabble.com/file/p27520625/config.log config.log 
-- 
View this message in context: http://old.nabble.com/Help-building-gcc-tp27520625p27520625.html
Sent from the gcc - Help mailing list archive at Nabble.com.



More information about the Gcc-help mailing list