Fwd: Building gcc-4.3.2 using gcc-g++3.3.3

Franklyn Simon franklynsimon@bellsouth.net
Thu Jan 29 21:55:00 GMT 2009


Forget attachments

>Date: Thu, 29 Jan 2009 16:53:04 -0500
>To: Kai Ruottu <kai.ruottu@wippies.com>, gcc-help@gcc.gnu.org
>From: Franklyn Simon <franklynsimon@bellsouth.net>
>Subject: Building gcc-4.3.2 using gcc-g++3.3.3
>
>I have SUSE Linux Enterprise Server 9 (SLES9) 
>with gcc-g++3.3.3 and make3.80-184.1 installed 
>on i686-pc.  I am trying to migrate from IRIX6.2 
>OS to Linux.  However, I am having several 
>problems with compiling the source codes.  Some 
>of the problems are with c++ stream as well as 
>return a char* to the calling 
>function.  Therefore, I am trying to install 
>gcc-4.3.2 with the upgrade gcc-g++ compiler, but 
>I am still using the current and old gcc with 
>make3.80-184.1 to build gcc-4.3.2.  I cannot 
>trust this compiler, and I am wondering if this 
>is the problem I might be having building gcc-4.3.2.
>
>I have run out of options in building 
>gcc-4.3.2.  I cannot configure and build 
>gcc-4.3.2, gmp-4.2.4, and mpfr-2.3.2 
>together.  I have to configure and build gmp and 
>mpfr separately to get the library and include 
>files to be generated.  Also, depending on where 
>I build them, I might have to do a make 
>distclean when it is time to build 
>gcc-4.3.2.  The attached is the configuration 
>files and make –j1.  I have tried all the 
>suggestions to build gcc-4.3.2 from gcc help as 
>well as following the directions from 
><http://gcc.gnu.org/install>http://gcc.gnu.org/install
>Also just before make failed, there were several 
>warning message: duplicate const
>
>
>
>Do you have any suggestions to help me?
>
>Thanks
>
>
>At 07:05 AM 1/26/2009, you wrote:
>>Franklyn Simon wrote:
>>
>>>Here is the attached config.log file and output from make -j1
>>>It appears that configuration was okay, but I cannot get to build.
>>>After looking at the config.log file its 
>>>indicates the following two possible 
>>>errors.  I do not know how to go about solving then
>>>Please help. I am using gcc-g++3.3.3 compiler 
>>>and SLES9 on hp pavilion a305w (i686-pc).  I am going a native build
>>
>>Your log tells that you aren't trying to build "only gcc-4.3.2" but to
>>try some kind of "everything at the same time" : binutils, gmp, GCC,...
>>and your build crashing during the 'gmp' build...
>>
>>Traditionally these things have been splitted into smaller pieces so the
>>GNU binutils, the GCC, the 'gmp' etc. sources are 'stand-alone' with
>>their own 'bfd', 'libiberty' etc. subdirs.  But there can be those
>>"combined GNU sources" like those GNUpro ones from Red Hat and in them
>>builds like yours should work. But in them many people have worked in
>>order to get things to work together.
>>
>>Ok, something is wrong in your 'gmp' source install :
>>
>>----------- clip -------------
>>make[3]: Leaving directory `/usr/local/gcc-4.3.2/binutils'
>>Configuring stage 1 in ./gmp
>>configure: loading cache ./config.cache
>>checking build system type... i686-pc-linux-gnu
>>checking host system type... none-pc-linux-gnu
>>checking for a BSD-compatible install... /usr/bin/install -c
>>checking whether build environment is sane... yes
>>checking for gawk... gawk
>>checking whether make sets $(MAKE)... yes
>>make[2]: Leaving directory `/usr/local/gcc-4.3.2'
>>make[1]: Leaving directory `/usr/local/gcc-4.3.2'
>>
>>configure: error: source directory already configured; run "make
>>distclean" there first
>>make[2]: *** [configure-stage1-gmp] Error 1
>>----------- clip -------------
>>
>>The GCC's "Prerequisites" say that the 'gmp-*' and 'mpfr-*' sources
>>could be installed as 'gmp' and 'mpfr' subdirs into the GCC sources.
>>Did you really do this?  Not for instance installing them being
>>"parallel with the GCC sources" ?
>>
>>Building binutils then happens "parallel", totally separately from
>>the GCC sources so one can have '$src/gcc-4.3.2' and
>>'$src/binutils-2.19' but '$src/gcc-4.3.2/gmp' and '$src/gcc-4.3.2/mpfr'
>>for the 'gmp-*' and 'mpfr-*' sources...
>>
>>The $build directory should be a separate one from the sources...
>>Where are your GCC sources? They MUST NOT be in '/usr/local' ! Using
>>that as your chosen '$build' directory sounds really weird. Something
>>like :
>>
>>   /usr/local/src
>>
>>for the unpacked srcs like '/usr/local/src/gcc-4.3.2',
>>'/usr/local/src/gmp-4.2.1', '/usr/local/src/mpfr-2.3.2' etc. would
>>be more "normal". After unpacking the srcs there a suitable $build
>>directory could be the :
>>
>>  /usr/local/build
>>
>>and configuring & building there... Just as the "Install" Prerequisites
>>are telling, one could then have in '/usr/local/src/gcc-4.3.2' :
>>
>>    gmp -> ../gmp-4.2.1
>>    mpfr -> ../mpfr-2.3.2
>>
>>and both 'gmp' and 'mpfr' being built during the GCC build....
>>
>>The '/usr/local' is quite like '/usr' in a Linux system, aimed for
>>local-made apps ('bin'), libraries ('lib'), headers ('include') etc.
>>Anything might happen if one thinks that it is not used for anything
>>in the system...  I myself use '/home/src' as the install place for
>>all kind of source distributions...
>>
>>I tried the "build 'gmp' and 'mpfr' during the gcc-4.3.2 build and
>>things seemed to work even in a $build != $host case (cross-compiling
>>also 'gmp' and 'mpfr' for the '$host' platform while producing GCC
>>binaries for that...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 25956 bytes
Desc: not available
URL: <https://gcc.gnu.org/pipermail/gcc-help/attachments/20090129/429b1063/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: makej1.log
Type: application/octet-stream
Size: 16468 bytes
Desc: not available
URL: <https://gcc.gnu.org/pipermail/gcc-help/attachments/20090129/429b1063/attachment-0001.obj>


More information about the Gcc-help mailing list