compiling gcc 4.3.2 on hpux 10.20: no target 'all'

omar_zakaria@agilent.com omar_zakaria@agilent.com
Wed Jan 28 00:42:00 GMT 2009


> -----Original Message-----
> From: Kai Ruottu [mailto:kai.ruottu@wippies.com]
> Sent: Tuesday, January 27, 2009 2:30 AM
> To: ZAKARIA,OMAR (A-USA,ex1)
> Cc: gcc-help@gcc.gnu.org
> Subject: Re: compiling gcc 4.3.2 on hpux 10.20: no target 'all'
> 
> omar_zakaria@agilent.com wrote:
> 
> >> Is the guessed system name among the "supported" in 'configure'?
> >
> > config.guess reports that my system is an hppa2.0-hp-hpux10.20 machine.
>  > However, I would like to build gcc using hppa1.1-hp-hpux10.20,
>  > which I believe is supported. The configure script's
>  > documentation says that the host and target systems will
>  > default to the build system unless otherwise specified.
> 
> The 'config.log' could tell what was thought about the host and target.
> 
> My own attitude is that "computers are stupid and should not let guess
> anything" :) So nowadays I always tell all the three systems, mainly
> because I build only crosscompilers, never any native ones. And not
> much for the current (temporary) installed system but for "more wide
> audience" (should run on older systems too)...

Heh. I spent 5 years getting my undergrad in CS. Computers're the dumbest things I've met with the exception of incoming Freshmen CS majors ( ;-). Just joking, all you Freshmen out there!).

For what it's worth, I tried defining all three and it still didn't generate the gcc makefile (as you pointed out below).
 
> For pure curiosity I tried a cross-GCC for the 'hppa1.1-hp-hpux10.20'
> target yesterday evening and got :
> 
> [root@Dell gcc]# pwd
> /data1/home/src/gcc-4.3.2/build/gcc
> [root@Dell gcc]# ./xgcc -v
> Using built-in specs.
> Target: hppa1.1-hp-hpux10.20
> Configured with: ../configure --build=i686-linux-gnu
> --host=i686-linux-gnu --target=hppa1.1-hp-hpux10.20
> --enable-languages=c,c++ --enable-objc-gc
> Thread model: single
> gcc version 4.3.2 (GCC)
> 
> (the build stopped after 'gcc' when I had no target binutils, headers or
> libs for this target)
> 
> which tells that this target name passed OK into 'gcc' and resulted
> producing GCC binaries there...
> 
> Maybe you should check those "Prerequisites" for GCC installation:
> GNU make, working 'sh' like 'bash', working 'tar' (errors in unpacking

Someone else on another forum suggested the same thing: downloading the latest binutils, compiling them, and seeing what happens. In an effort to make as few assumptions as possible about the validity of any of the programs, I'm currently building the latest and greatest everything that will compile on this old B2000.

I'll let you all know how it turns out.

> the GCC sources) etc. As a Linux-user it is easy to forget that not
> everyone has 'bash', 'GNU make', 'GNU tar' etc. And new enough versions
> for them....

Seriously.
Even more frustrating is that HP-UX 10.20 actually /has/ a lot of these programs, but they're all ancient and buggy; 10.20 apparently has some near-legendary bugs in it.

Thanks for your help. I'll let you know how it turns out.

-- 
Omar




More information about the Gcc-help mailing list