unrecognized command line option "-fgnu-linker"

Andrew Haley aph@redhat.com
Wed Jan 14 11:33:00 GMT 2009


vaxira wrote:
> I am attempting to recompile avlmap library code that is six years old. I
> compiled the code mummer of times with GCC 2.95.3,  3.1.1,  3.2.3. and
> 3.4.4. No more luck. 
> Invariably I get the following:  
> 
> cc1: error: unrecognized command line option "-fgnu-linker"
> cc1: error: unrecognized command line option "-fmove-all-movables"
> make[1]: *** [obj/arlib/avlmap/avl_abort.o] Error 1
> 
> Can anyone advice?

Yes.  Edit your makefiles, removing old cruft like -fgnu-linker" and
"-fmove-all-movables".

Andrew.



More information about the Gcc-help mailing list