Fwd: mips 16 bit compilation lead to crash

Nick Clifton nickc@redhat.com
Tue Aug 18 14:06:00 GMT 2009


Hi Keshav,

> I am using binutils GNU ld (GNU Binutils) 2.17.50.20070611.

Actually you are running into a problem with the assembler (gas) not the 
linker (ld).  Also version 2.17 is quite old now.  We are currently on 
version 2.19 and the development sources are even more advanced.

> and my test program is

How was your toolchain configured ?

I tried building your testcase with a toolchain configured for a 
mipsisa32-elf target and using today's gcc and binutils sources and it 
had no problems at all.

Perhaps you just need to upgrade you toolchain ?

Cheers
   Nick



More information about the Gcc-help mailing list