gcc 3.4.6 build failure Solaris 5.8

Shaun Deacon sdeacon@fma.fujitsu.com
Tue Aug 4 21:37:00 GMT 2009


Hi Andrew,


Andrew Haley wrote:
> 
> Well, it's a libtool bug in a very old version of gcc.
> To start with, try running the command that starts with "bin/sh ./libtool
> " on
> its own, and we can try to figure out what's going wrong.
> 

When I run the '/bin/sh ./libtool ...' command standalone in the same
directory, the same error occurs :

  libtool: link: link input file `' does not exist

I did notice 'libgcj.objectlist' doesn't exist, is this the input file that
is being referred to ?

Thanks for your help,
Shaun

For reference I ran the following :

%> cd /home/sdeacon/tools/gcc/build/sparc-sun-solaris2.8/sparcv9/libjava
%> /bin/sh ./libtool --tag=CXX --mode=link
/home/sdeacon/tools/gcc/build/gcc/xgcc -shared-libgcc
-B/home/sdeacon/tools/gcc/build/gcc/ -nostdinc++
-L/home/sdeacon/tools/gcc/build/sparc-sun-solaris2.8/sparcv9/libstdc++-v3/src
-L/home/sdeacon/tools/gcc/build/sparc-sun-solaris2.8/sparcv9/libstdc++-v3/src/.libs
-B/home/sdeacon/gcc/sparc-sun-solaris2.8/bin/
-B/home/sdeacon/gcc/sparc-sun-solaris2.8/lib/ -isystem
/home/sdeacon/gcc/sparc-sun-solaris2.8/include -isystem
/home/sdeacon/gcc/sparc-sun-solaris2.8/sys-include  -m64
-L/home/sdeacon/tools/gcc/build/sparc-sun-solaris2.8/sparcv9/libjava -g -O2 
-m64 -m64 -o libgcj.la -objectlist libgcj.objectlist \
../boehm-gc/libgcjgc_convenience.la ../libffi/libffi_convenience.la
../zlib/libzgcj_convenience.la \
-rpath /home/sdeacon/gcc/lib/sparcv9 -rpath /home/sdeacon/gcc/lib/sparcv9 
-lpthread -lrt ./libltdl/libltdlc.la  -version-info `grep -v '^#'
../../../../gcc-3.4.6/libjava/libtool-version`

-- 
View this message in context: http://www.nabble.com/gcc-3.4.6-build-failure-Solaris-5.8-tp24704058p24816767.html
Sent from the gcc - Help mailing list archive at Nabble.com.



More information about the Gcc-help mailing list