Problems Building ppl-0.10.2 with g++-4.4.0 on Open Solaris 2008.11

Roberto Bagnara bagnara@cs.unipr.it
Sun Apr 26 10:16:00 GMT 2009


Tom Browder wrote:
> [...] I've been compiling gcc since
> before egcc and it really doesn't look like a Solaris problem but a
> ppl problem.

On what grounds are you claiming that?  Did you investigate the problem?
I mean, you seem to ignore that we actually test all PPL candidate releases
on dozens of different hardware/software platforms.  And that we refrain
from releasing if even the slightest problem is known to us.

> [...]   I suspect g++-4.4.0 is too strict for ppl and ppl needs
> fixing.

Suspect?  Are you suspecting that we released PPL 0.10.x without
testing it with the GCC 4.4.0 snapshots and release candidate?
Regards,

    Roberto

P.S.: Suggested reading:

       http://www.catb.org/~esr/faqs/smart-questions.html#id306810
       http://www.catb.org/~esr/faqs/smart-questions.html#symptoms

-- 
Prof. Roberto Bagnara
Computer Science Group
Department of Mathematics, University of Parma, Italy
http://www.cs.unipr.it/~bagnara/
mailto:bagnara@cs.unipr.it



More information about the Gcc-help mailing list