gcc-4.4.0,

Kate Minola kate01123@gmail.com
Thu Apr 23 13:24:00 GMT 2009


Hi,

http://gcc.gnu.org/install/prerequisites.html says that the
following two new (to me) packages are required to build gcc-4.4.0
from source:

1. Parma Polyhedra Library (PPL) version 0.10
2. CLooG-PPL version 0.15

Some questions:

1. gcc-4.4.0 and previous snapshots seem to build just fine
without my having these two packages on my system.  Are they
REALLY required ... or just recommended?  (Sort of like you did
for gmp and mpfr.  There were recommended for a release, and
then for the next major release they were required.)

2. The Graphite loop optimizations - are they automatic if PPL and
CLooG are installed in gcc ... or are they only used if you use the
compile paramenters mentioned in the GCC 4.4.0 Change notes in

     http://gcc.gnu.org/gcc-4.4/changes.html
-- 
Kate Minola



More information about the Gcc-help mailing list