gcc include path problem?

vicpk4 gavrilov_victor@mail.ru
Mon Jun 16 15:52:00 GMT 2008


Hi!
Yes, it's not a gcc issue.
GCC uses the correct headers, and my guess was wrong.
I tried simple test.c with OpenGL, gcc compiles it without any errors.
The problem lies in my config.h. Some combination of its DEFINE's leads to
this error in glext.h. It seems that type ptrdiff_t is undefined with my
configuration.
When I remove config.h from include's, no error appears.

Thanks!
Victor.


Eus-2 wrote:
> 
> Hi Ho!
> 
> Have you tried `-lglut', for example, `gcc -o show_triangle
> show_triangle.c -lglut'?
> 
> AFAIK, Slackware puts libglut.so in /usr/X11R6/lib/.
> 
> If that does not work, just tell us.
> 
> I think this topic is not suitable for this mailing list because this has
> nothing to do with GCC. But, I maybe wrong anyway.
> 
> Best regards,
> Eus      
> 
> 

-- 
View this message in context: http://www.nabble.com/gcc-include-path-problem--tp17815830p17867473.html
Sent from the gcc - Help mailing list archive at Nabble.com.



More information about the Gcc-help mailing list