Compiling instructions unclear gcc-4.3.0

Nick England nickengland@gmail.com
Fri Jun 6 15:24:00 GMT 2008


Yes, I downloaded the source and dependancies previously to running
the configure.

machine is a x86_64 running SUSE linux

I re-ran the
../gcc-4.3.0/configure --prefix=/foo --with-mpfr=/bar
and this time it generated a makefile in the objdir.

I have no idea why it didn't do so the first time. (I overwrote the
config.log unfortunately) I don't remmeber it ending with an error the
first time though.

however now the build fails when I run "make" with:
make[3]: Entering directory `/home/nwe23/software/gccbuild/gcc'
TARGET_CPU_DEFAULT="" \
        HEADERS="auto-host.h ansidecl.h" DEFINES="" \
        /bin/sh ../../gcc-4.3.0/gcc/mkconfig.sh config.h
TARGET_CPU_DEFAULT="" \
        HEADERS="options.h config/i386/biarch64.h config/i386/i386.h
config/i386/unix.h config/i386/att.h config/dbxelf.h config/elfos.h
config/svr4.h config/linux.h config/i386/x86-64.h
config/i386/linux64.h defaults.h" DEFINES="UCLIBC_DEFAULT=0" \
        /bin/sh ../../gcc-4.3.0/gcc/mkconfig.sh tm.h
gawk -f ../../gcc-4.3.0/gcc/opt-gather.awk
../../gcc-4.3.0/gcc/ada/lang.opt ../../gcc-4.3.0/gcc/fortran/lang.opt
../../gcc-4.3.0/gcc/java/lang.opt
../../gcc-4.3.0/gcc/treelang/lang.opt ../../gcc-4.3.0/gcc/c.opt
../../gcc-4.3.0/gcc/common.opt
../../gcc-4.3.0/gcc/config/i386/i386.opt
../../gcc-4.3.0/gcc/config/linux.opt > tmp-optionlist
/bin/sh ../../gcc-4.3.0/gcc/../move-if-change tmp-optionlist optionlist
echo timestamp > s-options
gawk -f ../../gcc-4.3.0/gcc/opt-functions.awk -f
../../gcc-4.3.0/gcc/opth-gen.awk \
               < optionlist > tmp-options.h
/bin/sh ../../gcc-4.3.0/gcc/../move-if-change tmp-options.h options.h
echo timestamp > s-options-h
TARGET_CPU_DEFAULT="" \
        HEADERS="auto-host.h ansidecl.h" DEFINES="" \
        /bin/sh ../../gcc-4.3.0/gcc/mkconfig.sh bconfig.h
gcc -c   -g -fkeep-inline-functions -DIN_GCC   -W -Wall
-Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes
-Wold-style-definition -Wmissing-format-attribute -fno-common
-DHAVE_CONFIG_H -DGENERATOR_FILE -I. -Ibuild -I../../gcc-4.3.0/gcc
-I../../gcc-4.3.0/gcc/build -I../../gcc-4.3.0/gcc/../include
-I../../gcc-4.3.0/gcc/../libcpp/include -I/home/nwe23/bin/include
-I../../gcc-4.3.0/gcc/../libdecnumber
-I../../gcc-4.3.0/gcc/../libdecnumber/bid -I../libdecnumber    -o
build/errors.o ../../gcc-4.3.0/gcc/errors.c
build/genmodes -h > tmp-modes.h
/bin/sh: build/genmodes: No such file or directory
make[3]: *** [s-modes-h] Error 127
make[3]: Leaving directory `/home/nwe23/software/gccbuild/gcc'
make[2]: *** [all-stage1-gcc] Error 2
make[2]: Leaving directory `/home/nwe23/software/gccbuild'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory `/home/nwe23/software/gccbuild'
make: *** [all] Error 2


2008/6/6 Eljay Love-Jensen <eljay@adobe.com>:
> Hi Nick,
>
> It appears that your configure failed.
>
> The config.log should indicate what failed.
>
> What is your configure line?
>
> What platform are you using?
>
> Did you complete step #1 (prerequisites)?
>
> I presume you completed step #2 (downloading GCC source) or you wouldn't
> have gotten to step #3 (configure).
>
> Thanks,
> --Eljay
>
>



More information about the Gcc-help mailing list