gcc3 ABI compatibility?

Ian Lance Taylor iant@google.com
Thu Jun 5 14:19:00 GMT 2008


Andrew Haley <aph@redhat.com> writes:

> Probably.  The multi-vendor C++ ABI made this a lot better, but there are
> still incompatibilities.  We don't break ABI compatibility on release branches,
> so you can safely assume that 3.4.2 is compatible with 3.4.1.

And across release branches, it is worth knowing about the
-fabi-version option.

Ian



More information about the Gcc-help mailing list