build 64-bit gcc-4.2.2 on Solaris 9

Jim Wilson wilson@tuliptree.org
Mon Apr 14 19:49:00 GMT 2008


Poor Yorick wrote:
> I'm trying to build 64-bit gcc-4.2.2 on Solaris 9, but I keep getting 32-bit files in the build.  I've tried various values for --host,  --target,  CFLAGS, and LDFLAGS, but no joy.  I modified GCC_FOR_TARGET right before running make, and finally got a 64-bit gcc/crt1.o, but then intl/config tried to make more 32-bit objects.  I've looked around the documentation, and back through a couple of years of the mailing list without luck.  Could someone please clue me in on how to tell gcc to be 64-bit?

I don't have a sparc machine here, but I believe most sparc-solaris 
builds support both 32-bit and 64-bit code.  You get 64-bit code with 
-m64 and 32-bit code with -m32.  So yes, you will have 32-bit files in 
the build even when building a gcc that emits 64-bit code.  This isn't a 
problem.

If you want 64-bit code only, you can configure for 
sparc64-sun-solaris2.10 (or whatever Solaris version you have) and also 
specify --disable-multilibs to turn off support for the 32-bit libraries.

You might need to be more specific about what you want here.  You want a 
gcc compiled as 64-bit code or a gcc that emits 64-bit code or both?

Jim



More information about the Gcc-help mailing list