C++ compiler cannot create executables

Tim Prince tprince@computer.org
Fri Sep 14 15:20:00 GMT 2007

> ---------- Forwarded message ----------
> From: IVAN ANGELOV <ivangotoy@gmail.com>
> Date: 14.09.2007 10:11
> Subject: C++ compiler cannot create executables
> To: gcc-help@gcc.gnu.org
> Yesterday (13.09.2007) I downloaded the full GCC trunk from svn. It
> was around 300 mb in size. I followed the installation instructions as
> much as I could.
> I made objdir on my desktop and I ran :
>  /home/ivan/Desktop/gcc/configure --prefix=/usr/local/gcc/gcc- 4.3.0
> --enable-shared --enable-threads=posix --enable-tls
> --with-gmp=/usr/lib --with-mpfr=/usr/lib
> then I ran make bootsrap and went to bed. I didn't have enough
> patience to wait for the tests make -k check process and I commited
> make install :)
> then I symbolically linked gcc , cpp , g++ c++ gccbug gcj gcov
> gfortran from :/usr/local/gcc/gcc-4.3.0/bin to /usr/bin
> then I simply tried to ./configure a piece of code and the shell said:
> checking for C++ compiler default output file name... configure:
> error: C++ compiler cannot create executables
> See `config.log' for more details.
> The config.log points out:
> configure:2113: g++    conftest.cc  >&5
> /usr/bin/ld: crtbegin.o: No such file: No such file or directory

The part about symlink surely wasn't in the installation instructions.
You don't want to set up a build in such a way that your original gcc
can be trashed.  Test your new compiler in a separate installation from
the original, or before installing.  Then, if you want to replace the
compiler in /usr/bin, reconfigure with -prefix=usr and install.

More information about the Gcc-help mailing list