Help in installing GCC 4.2.0!

leehj leehj@csse.unimelb.edu.au
Fri Sep 14 13:35:00 GMT 2007


Hi again,


>From previous email(with Tim's answer in BOLD) and my latest question right
after that with (Lee:) :-

Thanks for the prompt reply.

 I am aware that its my mistakes in the "\".
 I managed to get the BIN folder installed on the root however, when i
try to "make install" on the gccobj and gcc4.2.0 folder it
returns me minor error such as:-

 make[1]: Entering directory `/mount/autofs/home_pgrad/leehj/gcc-4.2.0'
/bin/sh ./mkinstalldirs /usr/local /usr/local
 /bin/sh: host-i386-pc-solaris2.9/fixincludes: does not exist
 make[1]: *** [install-fixincludes] Error 1
 make[1]: Leaving directory `/mount/autofs/home_pgrad/leehj/gcc-4.2.0'
make: *** [install] Error 2

 Does it really matter?

How do I proceed on from here to compile the gcc code? What do we needto
do with the BIN folder and the GCCOBJ folder? Are we suppose to put the
 source file(.C file) in the GCCOBJ folder? or the main folder?



Tim Prince wrote:
> 
> Hua Jie Lee wrote:
> 
>> I created an object directory before configure them. I did follow the FAQ
>> of GCC to set the path of --prefix=dirname by settings as:-
>> 
>> .../gcc-4.2.0/configure --prefix=$HOME\bin\gcc420\
>> 
>> After the make configure it returned few errors such as :-
>> 
>> mkdir /home/student/leehjbingcc420
>> mkdir: Failed to make directory "/home/student/leehjbingcc420";
>> Permission
>> denied
> 
> It looks like you have been confused by running Windows. Read up about
> the meaning of '\' in your OS.  You may have meant something like
> $HOME/gcc420  Note that it is a little nonsensical to ask your gcc build
> to install in directories something/bin/gcc420/bin,
> something/bin/gcc420/lib, something/bin/gcc420/info, ...
> but you can do that if you like.
> 
> 


Please keep your reply on the correct list, and use normal bottom
posting and text (not html).  I'm sorry, I neglected to fix your
cross-posting the first time, which no doubt earned both of us some
enemies.
Do you have write privilege on all the directories your build is trying
to create?


Lee: It should have write privilege as well for me. Anyway, how could I
check it up for the privilege? 
ll on gcc-4.2.0?

And another matter, i have removed the overall files as I tried to compile
using GCOV. However, upon a.out there is still no response and the file is
empty. Any good suggestion when I tried reinstall again?

Where exactly should be the executables (.obj) stored in? Is it the folder
on the PREFIX I should set or is it compiled together in the same folder in
gcc-4.2.0?

Please advise.


Cheers,
Lee


-- 
View this message in context: http://www.nabble.com/Help-in-installing-GCC-4.2.0%21-tf4412693.html#a12670965
Sent from the gcc - Help mailing list archive at Nabble.com.



More information about the Gcc-help mailing list