binary compatibility between gcc 3.4.3 and 4.x

Ian Lance Taylor iant@google.com
Thu Sep 28 07:59:00 GMT 2006


"Rathi, Dinesh" <drathi@informatica.com> writes:

> Are these versions binary compatible with each other on Linux 64 (intel
> arch)? I need to use a shared library built using gcc 3.4.3 and will be
> building my executable using gcc 4.1.1.

They are generally compatible.  There are some obscure C++ corner
cases where they are not compatible, but you are very unlikely to
encounter them.

If you ask a question along these lines in the future, be sure to
specify which language you are asking about.

Ian



More information about the Gcc-help mailing list