going from gcc v3.2.2 to v 4.1

David Fang fang@csl.cornell.edu
Tue Sep 12 18:54:00 GMT 2006


> I have some C++ code that compiles and links fine under gcc 3.2.2 (Red
> Hat 9). I have just migrated to Fedora Core 5. This code will not
> build using gcc 4.1 and I am at a lose as to where to begin fixing
> this.
>
> I have recently read about how the C++ ABI was recently
> changed/finalized and that now gcc follows the standard better.
> Wonderful. However, knowing this does not really help me resolve the
> problem at hand--that is, my existing code will not build using gcc
> 4.1.
>
> Is there any migration guide (hopefully with examples) available that
> specifies where you guys made changes to gcc that will break existing
> code?

Hi,

For starters,

http://gcc.gnu.org/gcc-3.3/changes.html
http://gcc.gnu.org/gcc-3.4/changes.html
http://gcc.gnu.org/gcc-4.0/changes.html
http://gcc.gnu.org/gcc-4.1/changes.html
http://gcc.gnu.org/gcc-4.2/changes.html

... should bring you up to date.  :)

> Are there any other recourses available to help with migration issues
> like this?
>
> Thank you for any help you can provide.


Fang



More information about the Gcc-help mailing list