gcc version compatibility resolution

Tim Prince timothyprince@sbcglobal.net
Sun Nov 5 10:59:00 GMT 2006


aquarius60 wrote:
> Hi, I'm wondering if it's possible to resolve compatibility issues 
> between different versions of gcc.
> I have an older program that I'm trying to install on FC6 which replies 
> with
> "This installation doesn't support glibc-2.1 on x86_64"
> "rpm -qa | grep gcc"  reveals  gcc-4.1.1-30
The only incompatibility you show is in the glibc; certainly, if it is 
dynamically linked, ldd could show you more problems.  If it is a 32-bit 
program, there's not much you can do easily, beyond installing all the 
32-bit compatibility libraries.  The next step would be to install a 
linux of the vintage expected by the program.




More information about the Gcc-help mailing list