Problems building gcc-4.0.2 on zSuSE 9

Eric Weinstein eric@ericweinstein.com
Wed Jun 7 15:38:00 GMT 2006


I'm attempting to build gcc 4.0.2 on zSuSE 9 (2.6.5-7.97-s390x kernel), and get the following errors during the make:

c-parse.y: In function `yyparse':
c-parse.y:342: error: `pedantic' undeclared (first use in this function)
c-parse.y:342: error: (Each undeclared identifier is reported only once
c-parse.y:342: error: for each function it appears in.)
c-parse.y:365: error: `warn_pointer_arith' undeclared (first use in this function)
c-parse.y:365: error: `warn_traditional' undeclared (first use in this function)
c-parse.y:1882: error: `warn_declaration_after_statement' undeclared (first use in this function)
make[1]: *** [c-parse.o] Error 1

I have used a variety of configure lines and none seem to have any effect. I used everything from no options, replicating the options on the 3.3.3 build to the options used on the build reports on gcc.gnu.org. A sampling of configure and make lines is below. 

I am using the installed 3.3.3 gcc for the building, and have built the latest versions of binutils, bison, flex, texinfo, and coreutils.

Is there some sort of patch or workaround? I have seen references to touching the c-parse.c and c-parse.y files, but that hasn't helped. I even deleted the c-parse.y file and allowed bison to recreate it with no success. 


I've tried these configure lines and make combinations:

Configure line: ../configure --enable-__cxa_atexit --disable-multilib --enable-languages=c,c++,objc
Make line: make

Configure line: ../configure --enable-shared --with-system-zlib --libexecdir=/usr/lib --enable-nls --without-included-gettext --enable-threads=posix --program-suffix=-4.0 --enable-__cxa_atexit --enable-libstdcxx-allocator=mt --enable-clocale=gnu --enable-libstdcxx-debug --enable-java-gc=boehm --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-4.0-1.4.2.0/jre --enable-mpfr --disable-werror --enable-checking=release s390-linux-gnu
Make line: time make

Configure line: ../configure
Make line: make

Configure line: ../configure --prefix=/asg/it/tools/zSuSE9_64bit/gcc/4.0.2 --with-local-prefix=/asg/it/tools/zSuSE9_64bit/gcc/4.0.2
Make line: make

Configure line: ../configure --enable-shared --with-system-zlib --libexecdir=/usr/lib --enable-nls --without-included-gettext --enable-threads=posix --program-suffix=-4.0 --enable-__cxa_atexit --enable-libstdcxx-allocator=mt --enable-clocale=gnu --enable-libstdcxx-debug --enable-java-gc=boehm --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-4.0-1.4.2.0/jre --enable-mpfr --disable-werror --enable-checking=release s390-linux-gnu
Make line: time make

Configure line: ../configure --prefix=/asg/it/tools/zSuSE9_64bit/gcc/4.0.2 --with-local-prefix=/asg/it/tools/zSuSE9_64bit/gcc/4.0.2
Make line: time make

Configure line: ../configure --enable-__cxa_atexit --disable-multilib --enable-languages=c
Make line: make bootstrap

Configure line: ../configure --prefix=/asg/it/tools/zSuSE9_64bit/gcc/4.0.2 --with-local-prefix=/asg/it/tools/zSuSE9_64bit/gcc/4.0.2 --enable-__cxa_atexit --disable-multilib --enable-languages=c,c++
Make line: make

Configure line: ../configure
Make line: make

Configure line: ../configure
Make line: make bootstrap

Configure line: ../configure --prefix=/build/gcc/gcc-4.1.1-install --enable-shared --with-system-zlib --enable-threads=posix --enable-__cxa_atexit --program-suffix=-4.1.1 --enable-languages=c
Make line: make

I made similar attempts with gcc-4.0.3, but c-parse.c hasn't changed, so I get the same result.

Any advice would be greatly appreciated. Thanks for your time!



More information about the Gcc-help mailing list