Problem installing qlapadmin on FC3.

Its Azfar azfarhusain@yahoo.com
Tue Jan 24 11:57:00 GMT 2006


I am trying to install QLDAPAdmin on FC3. I followed
the documentation but getting these errors on "make".

g++ -O2 --pipe  -I/usr/local/include -c -o
LDAPException.o LDAPException.cpp
In file included from LDAPException.cpp:14:
LDAPException.h:30: error: ISO C++ forbids declaration
of `ostream' with no type
LDAPException.h:30: error: `ostream' is neither
function nor member function; cannot be declared
friend
LDAPException.h:30: error: expected `;' before '&'
token
LDAPException.cpp:16: error: default argument given
for parameter 2 of `LDAPException::LDAPException(int,
char*)'
LDAPException.h:26: error: after previous
specification in `LDAPException::LDAPException(int,
char*)'
LDAPException.cpp:48: error: expected constructor,
destructor, or type conversion before '&' token
LDAPException.cpp:48: error: expected `,' or `;'
before '&' token
make: *** [LDAPException.o] Error 1

How do I install qldapadmin on linux.
My gcc version is 3.4.2-6.
Any help.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 



More information about the Gcc-help mailing list