gcc-3.4.4 and the '-I' switch.

Sisyphus sisyphus1@optusnet.com.au
Thu Jan 12 00:12:00 GMT 2006


Hi,
On linux I'm using gcc 3.2.2. If I run a command like:

gcc -c foo.c -I/usr/include -v

then I'm told that '-I/usr/include/' is being ignored "as it is a non-system
directory that duplicates a system directory".

That's good - and the way it should be, imho.

On Win32 I'm using the MinGW port of gcc 3.4.4. One of the system
directories is 'D:/MinGW/include'. If, on Win32, I run a command like:

gcc -c foo.c -ID:/MinGW/include -v

then I find that D:/MinGW/include is simply inserted at the beginning of the
search path - and, furthermore, that D:/MinGW/include *loses* its status as
a system directory.

This is not good.

The question:
Do I raise this with you people, or do I raise it with the MinGW folk ?

I *think* it's a MinGW implemenation issue (in which case I raise it with
them) .... but, faik, it could be something that changed between gcc-3.2.2
and gcc-3.4.4. Can someone confirm ?

Cheers,
Rob




More information about the Gcc-help mailing list