Complex expression. Absolute segment assumed.

Glen Miner shaggie76@hotmail.com
Tue Nov 8 04:18:00 GMT 2005


I'm running a dual G5 / MacOS / Tiger machine and I tried to bootstrap from 
the gcc that comes with XCode 2.1 (4.0.0) up to 4.0.2 ). The bootstrap went 
fine however when I try to compile our code I get reams of errors like

/var/tmp//cc2Ol4cR.s:291056:Complex expression. Absolute segment assumed.
/var/tmp//cc2Ol4cR.s:291058:Complex expression. Absolute segment assumed.
/var/tmp//cc2Ol4cR.s:291060:Complex expression. Absolute segment assumed.

It happens to a number of our source files and I haven't been able to track 
down what causes it.

I tried running the latest snapshot release and it only made the problem 
worse -- more files exhibited this problem.

I tried upgrading the binutils package to perhaps get a newer version of Gas 
but that didn't seem to help.

Anybody have any advice?




More information about the Gcc-help mailing list