Problem Building 32-bit gcc native compiler

Bell, Timothy timothy.bell@intergraph.com
Tue Jul 19 22:54:00 GMT 2005


I have plenty of space. The make bootstrap results in the same "differs"
errors. I'm trying to compile 3.3.3.

Thanks,
Tim

Timothy Bell
Senior Information Systems Consultant, Solutions Group
Intergraph Corporation (NASDAQ:INGR) 
170 Graphics Drive, Madison, AL 35758 
P 1.256.730.1531 F 1.256.730.1350 
timothy.bell@intergraph.com; www.intergraph.com




-----Original Message-----
From: Eljay Love-Jensen [mailto:eljay@adobe.com]
Sent: Tuesday, July 19, 2005 5:32 PM
To: Bell, Timothy; gcc-help@gcc.gnu.org
Subject: RE: Problem Building 32-bit gcc native compiler


Hi Tim,

Are you short on disk space?  If not, what does...

make bootstrap

...do?

When I built (GCC 3.4.3), I used the trick of narrowly specifying my PATH...

PATH=/net/export/share/gcc-3.2/bin:/bin:/usr/bin make -j 4 CFLAGS='-O'
LIBCFLAGS='-g -O2' LIBCXXFLAGS='-g -O2 -fno-implicit-templates'
bootstrap-lean

...which worked well for me.  Avoided some undesirable interactions with
Solaris's compiler.  I haven't tried to build GCC 4.0 from scratch yet,
though.

Oh, and my configure was...

PATH=/net/export/share/gcc-3.2/bin:/bin:/usr/bin \
 /export/eljay/gcc-3.4.3/configure \
 --prefix=/export/eljay/gcc34 \
 --enable-languages=c,c++ \
 --with-gnu-as \
 --with-as=/net/export/share/gcc-3.2/bin/as \
 --with-gnu-ld \
 --with-ld=/net/export/share/gcc-3.2/bin/ld \
 --enable-threads \
 --enable-shared \
 --disable-symvers \
 --disable-__cxa_atexit

...which has some Solaris-isms in there.  But just as an FYI, I thought I'd
pass it along.

--Eljay

reference...
http://gnu.miscellaneousmirror.org/software/gcc/gcc-4.0/buildstat.html



More information about the Gcc-help mailing list