Compilation error..

Ian Lance Taylor ian@airs.com
Mon Jul 18 05:51:00 GMT 2005


Oleg Kotsyurbiy <alexspike@mail.ru> writes:

> Tell, please, what am I doing wrong for correct compilation:
> in Fedora Core 4 Linux I'm trying to compile GCC 3.2.3 version.

It's a problem.  Older versions of gcc use a construct which newer
versions of gcc won't compile.  This makes it hard to bootstrap older
versions of gcc with newer versions.  This is indeed an absurd
situation.

If you must use gcc 3.2.3, and you must use Fedora Core 4, then I
think your best bet is to first build and install gcc 3.3.6, and then
use that to build gcc 3.2.3.

Ian



More information about the Gcc-help mailing list