libstdc++-v3 configuration not supported

Moser, Dan (GE Trans) Dan.Moser@Trans.ge.com
Tue Feb 22 09:12:00 GMT 2005


Corey,

Thanks for the response.  It is GREATLY appreciated.

Here is what I used:

binutils (v2.15)
configure --target=m68k-elf --prefix=/home/moser
make all install


gcc-core (gcc v3.4.3)
configure --target=m68k-elf --prefix=/home/moser --enable-languages=c --with-local-prefix=/home/moser/m68k-elf --without-headers --with-newlib --disable-shared
make all-gcc install-gcc


newlib (v1.13.0).
configure --target=m68k-elf --prefix=/home/moser
make all install info install-info

gcc (gcc v3.4.3)
configure --target=m68k-elf --prefix=/home/moser --enable-languages=c,c++ --with-local-prefix=/home/moser/m68k-elf
make all install

I also followed the exact same steps above for powerpc-eabi and got the same results on both Linux and Cygwin (don't have the versions handy but they are generally the latest and greatest).

For both targets, everything works great until libstdc++-v3 (gcc and g++ both make and seem to work ok).
I get a message telling me that libstdc++-v3 is not supported for the specified configuration.
So, trying to work around that, I tried to make libstdc++-v3 manually but the compilation fails due to some missing types.  I grep'd all files in the distribution for those types and they did not appear to exist anywhere.

Thanks again,
Dan


-----Original Message-----
From: corey taylor [mailto:corey.taylor@gmail.com]
Sent: Saturday, February 19, 2005 9:21 PM
To: Moser, Dan (GE Trans)
Cc: gcc-help@gcc.gnu.org
Subject: Re: libstdc++-v3 configuration not supported


Dan,

  What configuration where you using that produced this result anyway?

corey


On Sat, 19 Feb 2005 14:26:55 -0500, Moser, Dan (GE Trans)
<Dan.Moser@trans.ge.com> wrote:
> I am new to the GNU tools and have been trying for 3 days to build cross compilers for both powerpc-eabi and m68k.
> 
> I have tried the process under both Linux and Cygwin with the same results.
> 
> For either target, I am able to successfully build the binutils, gcc-core, newlib, and target  C compiler.
> 
> However, when I try to build a target C++ compiler, I get the message that libstdc++ is not supported under my specified configuration.
> 
> I have also tried to configure and make libstdc++-v3 manually but end up with a compile error (identical error on cygwin and linux).
> 
> The g++ compiler does build and seem to work ok, I just can't get libstdc++ built.
> 
> Could anyone tell me the proper way, or a work-around, if any, to accomplish this task?
> 
> I have looked at crosstool and build-crossgcc.sh as examples but I am hoping for a little more "spoon feeding", if possible.
> 
> I ultimately want to cross compile under Cygwin for the above mentioned 2 targets.
> 
> Thanks,
> Dan Moser
> 
>



More information about the Gcc-help mailing list