Compile software with old libraries.

Patrick Peters P.Peters@schmit.nl
Thu Apr 14 07:29:00 GMT 2005


A long time ago we have developed some software for a system with redhat 6.0.
Our development server was also based on RedHat 6.0. A couple of weeks a go
we switched to a new development server (dual opteron - 64 bit). the software still compiles
fine, but offcourse does not work on the redhat 6.0 based systems any more.

I want to be able to use the latest gcc compiler and compile my  software with the old 
libraries (glibc, libstdc++ etc) of the redhat 6.0 based system. I keep getting linker errors.
Does someone know a good link with a howto. Is it possible this way or do i need an
old compiler version?

Thanks in advance.

Best regards,


Patrick.





More information about the Gcc-help mailing list