g++ infinite loop

b u bnulbig@yahoo.com
Fri Jul 23 07:32:00 GMT 2004


A little additional info.

--- b u <bnulbig@yahoo.com> wrote:
> I am compiling a project with g++ 3.3.2 && 2.95.3. 

It compiles fine with 2.95.3;)

It only happens on -O2.

I've inspected the -E preprocessing and it looks fine.

It happens before assembly (-S).

To the list of tried, I've also tried non-inline
definitions and specifying __attribute__((noinline)).

mTop is a simple unsigned int.

------------------------------------------
g++ $(options) -v CProcess.cpp
Reading specs from
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/specs
Configured with: ../gcc-3.3.2/configure --prefix=/usr
--enable-languages=c,c++,objc --enable-threads=posix
--enable-__cxa_atexit --enable-clocale=gnu
--enable-shared --disable-nls
Thread model: posix
gcc version 3.3.2 (CRUX)
 /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/cc1plus
-quiet -v -I/src/lag/portable/dict
-I/src/lag/portable/gram -I/src/lag/portable/log
-I/src/lag/portable/frmwrk -I/src/lag/portable/io
-I/src/lag/x86/io -I/src/lag/portable/util
-D__GNUC__=3 -D__GNUC_MINOR__=3
-D__GNUC_PATCHLEVEL__=2 -D_GNU_SOURCE -DNDEBUG
-D_REENTRANT -D_THREAD_SAFE -D_REENTRANT Process.cpp
-D__GNUG__=3 -quiet -dumpbase Process.cpp
-march=pentium4 -auxbase Process -O2 -Wall -version -o
/tmp/cc6RSrS5.s
GNU C++ version 3.3.2 (CRUX) (i686-pc-linux-gnu)
        compiled by GNU C version 3.3.2 (CRUX).
GGC heuristics: --param ggc-min-expand=99 --param
ggc-min-heapsize=129311
ignoring nonexistent directory "/usr/local/include"
ignoring nonexistent directory
"/usr/i686-pc-linux-gnu/include"
#include "..." search starts here:
#include <...> search starts here:
 /src/lag/portable/dict
 /src/lag/portable/gram
 /src/lag/portable/log
 /src/lag/portable/frmwrk
 /src/lag/portable/io
 /src/lag/x86/io
 /src/lag/portable/util
 /usr/include/c++/3.3.2
 /usr/include/c++/3.3.2/i686-pc-linux-gnu
 /usr/include/c++/3.3.2/backward
 /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/include
 /usr/include
End of search list.

**** STALLS HERE ****

Thanks, Ben.


		
__________________________________
Do you Yahoo!?
Yahoo! Mail is new and improved - Check it out!
http://promotions.yahoo.com/new_mail



More information about the Gcc-help mailing list