build failed on solaris 9

J.D. Bronson
Thu Apr 22 23:57:00 GMT 2004

This resulted in a new error:

   /var/obj/gcc/xgcc -B/var/obj/gcc/ -B/usr/local/i386-pc-solaris2.9/bin/ 
-B/usr/local/i386-pc-solaris2.9/lib/ -isystem 
/usr/local/i386-pc-solaris2.9/include -isystem 
/usr/local/i386-pc-solaris2.9/sys-include -c -DHAVE_CONFIG_H -O2 -O2 
-mcpu=pentium4 -I. -I/var/gcc-3.4.0/libiberty/../include  -W -Wall 
-Wtraditional -pedantic -fpic /var/gcc-3.4.0/libiberty/fibheap.c -o 
pic/fibheap.o; \
else true; fi
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
/var/gcc-3.4.0/libiberty/fibheap.c: In function `fibheap_union':
/var/gcc-3.4.0/libiberty/fibheap.c:166: warning: implicit declaration of 
function `free'
/var/gcc-3.4.0/libiberty/fibheap.c: In function `fibheap_delete_node':
/var/gcc-3.4.0/libiberty/fibheap.c:285: error: `LONG_MIN' undeclared (first 
use in this function)
/var/gcc-3.4.0/libiberty/fibheap.c:285: error: (Each undeclared identifier 
is reported only once
/var/gcc-3.4.0/libiberty/fibheap.c:285: error: for each function it appears 
/var/gcc-3.4.0/libiberty/fibheap.c: In function `fibheap_consolidate':
/var/gcc-3.4.0/libiberty/fibheap.c:395: warning: implicit declaration of 
function `memset'
make[2]: *** [fibheap.o] Error 1
make[2]: Leaving directory `/var/obj/i386-pc-solaris2.9/libiberty'
make[1]: *** [all-target-libiberty] Error 2
make[1]: Leaving directory `/var/obj'
make: *** [bootstrap] Error 2

At 06:15 PM 4/22/2004, wrote:
>What if you ran /var/gcc-3.4.0/configure rather than getting to it via
>-----Original Message-----
>From: [] On
>Behalf Of J.D. Bronson
>Sent: Thursday, April 22, 2004 5:09 PM
>Subject: build failed on solaris 9
>Since i had troubles with solaris 10, I tried building gcc 3.4.0
>on solaris 9. I have been able to successfuly build gcc 3.3.3 on
>this same machine and using it to build gcc 3.4.0.
>If I try my old way, it will build but then the install fails (just like
>prior email...install-sh not found)
>If I build the recommended way (so that objdir is not any part of
>the build fails.
>I untarred gcc into /var/gcc-3.4.0
>then I created /var/obj
>and from /var/obj
>I ran configure as such:
>../gcc*/configure --with-as=/usr/local/bin/as \
>--with-ld=/usr/local/bin/ld --disable-nls --enable-threads \
>--enable-shared --enable-multilib --with-cpu=pentium4 \
>--enable-languages=c,c++,f77 \
>then I did 'make bootstrap'
>the build goes on for some time then
>checking for ar... ar
>checking for ranlib... ranlib
>checking for a BSD compatible install... ../gcc-3.4.0/install-sh -c
>checking for interface version number...
>checking for --enable-version-specific-runtime-libs... no
>grep: can't open ${top_srcdir}/../gcc/version.c
>checking for ld used by GCC... /usr/local/bin/ld
>checking if the linker (/usr/local/bin/ld) is GNU ld... yes
>checking for /usr/local/bin/ld option to reload object files... -r
>checking for BSD-compatible nm... /usr/local/i386-pc-solaris2.9/bin/nm
>checking how to recognise dependant libraries... pass_all
>checking for object suffix... o
>checking for ranlib... (cached) ranlib
>checking for strip... strip
>updating cache ./config.cache
>loading cache ./config.cache within ltconfig
>configure: error: libtool configure failed
>make[1]: *** [configure-target-libf2c] Error 1
>make[1]: Leaving directory `/var/obj'
>make: *** [bootstrap] Error 2
>But if srcdir = /var/gcc
>and objdir = /var/gcc/obj
>it will build 100% but fail install.
>J.D. Bronson
>Aurora Health Care // Information Services // Milwaukee, WI USA
>Office: 414.978.8282 // Email: // Pager: 414.314.8282

J.D. Bronson
Aurora Health Care // Information Services // Milwaukee, WI USA
Office: 414.978.8282 // Email: // Pager: 414.314.8282

More information about the Gcc-help mailing list