Error during "make bootstrap" during GCC 3.3 Creation

llewelly@xmission.com llewelly@xmission.com
Mon Apr 19 21:14:00 GMT 2004


Frank Krauss <fmfkrauss@mindspring.com> writes:

> Thank you for looking into my Problem.
> 
> 1.  Your 100% correct about the Binutils being at the wrong Level.
>      I somehow missed seeing that in the Pre-req section and I will look into
>      updating that.


See: http://xrl.us/bwvk , and also, www.gnu.org/software/binutils .

Questions about binutils go to binutils at sources.redhat.com 

> 2.  I believe that my problem is actually caused by your 2nd suggestion
>     concerning the level of GLIBC that I'm using.
>     I didn't see any mention of a need for a specific version of
> GLIBC.

I don't either. I was sure there was one when I wrote my last post,
    but now I think I was mistaken. I *do* know some additional
    libstdc++ testcase failures occur with glibc < 2.2.5, but that
    shouldn't prevent a bootstrap. 

> 
> 3.  In other words, do I have to update my GLIBC to a specific level
>     before updating GCC?  I was under the impression that it was
>     supposed to be done the opposite way, with first GCC getting updated
>     and then using it to update GLIBC.

It depends on circumstance. I don't know all of the details.

> 
> 4.  Would you know of any doc available to show the correct procedure
>      on updating these two Components?
> 
> I have enclosed the listing of my /lib/*libc* as you requested.
> 
> Thanks again for your assistance.
> 
> Frank
> 
> output of "ls -l /lib/*libc*"
> 
> -rwxr-xr-x   1 root     root      1245005 Aug 10  1999
> /lib/libc-2.1.1.so
[snip]

2.1.1 is a very old libc. Unfortunately, upgrading libc from sources
    is difficult and error-prone. (It's not for the faint of heart,
    it's not for people who don't have full system backups, and it's
    not for people who don't have sstaticly linked copies of essential
    tools in strategic places. Nor is it for people without rescue
    disks and spare install CDs.)

Normally one upgrades libc with linux-distro-supplied packages. You'll
    have to see your distro implementor for those.

Since libc is so difficult to upgrade, I suggest you try upgrading
    binutils first, and hope that solves your problem.



More information about the Gcc-help mailing list