make bootstrap failure -> libgcc.map: file format...

Andy Gabor ajgabor@ucdavis.edu
Mon Sep 9 15:19:00 GMT 2002


Turns out the answer for me was *not* to use GNU ld (binutils-2.13).

Configuring with:

setenv CC /opt/SUNWspro/bin/cc
../configure --enable-languages=c,c++ --with-ld=/usr/ccs/bin/ld

Solved this problem.

Andy



On 9/9/2002 Andy Gabor wrote:
>
>Hi,
>
>Installed current binutils.
>
>Tried to build gcc-3.2 of ss u10 running solaris 9.
>
>Configured with:
>
>setenv CC /opt/SUNWspro/bin/cc
>./configure --enable-languages=c,c++
>
>
>Build error:
>gcc/./_udivdi3.o libgcc/./_umoddi3.o libgcc/./_udiv_w_sdiv.o libgcc/./_udivmoddi4.o  libgcc/./unwind-dw2.o libgcc/./unwind-dw2-fde.o libgcc/./unwind-sjlj.o -lc && rm -f libgcc_s.so && ln -s libgcc_s.so.1 libgcc_s.so
>/usr/local/sparc-sun-solaris2.9/bin/ld:libgcc/./libgcc.map: file format not recognized; treating as linker script
>/usr/local/sparc-sun-solaris2.9/bin/ld:libgcc/./libgcc.map:1: parse error
>collect2: ld returned 1 exit status
>
>There have been reports of other problems with libgcc.map but slightly
>different error reports.
>
>Any insights appreciated
>
>Andy
>=====================================================================
>Andy Gabor - Department of Neurology, University of California, Davis
>ajgabor@ucdavis.edu (530)754-5036 (FAX)



More information about the Gcc-help mailing list