STL iterators in gcc 3.2

Alberto Garcia Raboso Alberto.Garcia.Raboso@cern.ch
Fri Oct 25 08:24:00 GMT 2002


I have just changed from Debian GNU/Linux to Gentoo GNU/Linux, which comes
with gcc 3.2.

I have tried to compile some programs that worked fine under gcc 2.95.x
and 3.1, but now I got some problems with them:

1.- Whereas I didn't need it before, now I have to use the "using
namespace std" directive if I want to use cout, cin,... and all this
stuff. Why the change?

2.- This is more serious. In my programs I use a lot of STL vectors, and
so, iterators too. When I had a method with a pointer argument, I passed a
random iterator to it. It worked fine with previous versions of gcc, but
not with 3.2. Is there any way to get it work or do I have to come back to
an older version?

Thanks in advance,

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Alberto Garcia Raboso
CERN / EP
CH-1211 Geneva 23, Switzerland
Office 40-2B-19 (+41 22 76 71626)
E-Mail: Alberto.Garcia.Raboso@cern.ch
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Well, farewell, my hobbits! You should come safe to your own
homes now, and I shall not be kept awake for fear of your
peril. We will send word when we may, and some of us may yet
meet at times; but I fear that we shall not all be gathered
together ever again.

                      The return of the King. J.R.R. Tolkien
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~



More information about the Gcc-help mailing list