can not find 'c++config.h' and 'c++io.h'

Kremp, Johannes Johannes.Kremp@gedas.de
Wed May 8 05:28:00 GMT 2002


hello,

i installed gcc-3.0.4 on aix 4.3 in '/usr/local'.
but now i get following messages:

g++ -DPACKAGE=\"gui\" -DVERSION=\"1.00\" -DHAVE_DLFCN_H=1  -I. -I.
-I/home/rvsfox/local/include/fox -I/home/ekjo/rvstop/src
-I/home/ekjo/rvstop/lcsapi/lcsapi -I/home/rvsfox/local/include  -DAIX   -c
-o table.o `test -f table.cpp || echo './'`table.cpp
In file included from /usr/local/include/bits/std_vector.h:62,
                 from /usr/local/include/vector:31,
                 from table.h:10,
                 from table.cpp:1:
/usr/local/include/bits/stl_algobase.h:64:28: bits/c++config.h: A file or
directory in the path name does not exist.
In file included from /usr/local/include/bits/stl_algobase.h:69,
                 from /usr/local/include/bits/std_vector.h:62,
                 from /usr/local/include/vector:31,
                 from table.h:10,
                 from table.cpp:1:
/usr/local/include/bits/type_traits.h:49:28: bits/c++config.h: Error 0
In file included from /usr/local/include/bits/stl_algobase.h:73,
                 from /usr/local/include/bits/std_vector.h:62,
                 from /usr/local/include/vector:31,
                 from table.h:10,
                 from table.cpp:1:
/usr/local/include/bits/std_cstdlib.h:37:28: bits/c++config.h: Error 0
In file included from /usr/local/include/bits/stl_algobase.h:77,
                 from /usr/local/include/bits/std_vector.h:62,
                 from /usr/local/include/vector:31,
                 from table.h:10,
                 from table.cpp:1:
/usr/local/include/bits/std_iosfwd.h:39:28: bits/c++config.h: Error 0
In file included from /usr/local/include/bits/std_iosfwd.h:40,
                 from /usr/local/include/bits/stl_algobase.h:77,
                 from /usr/local/include/bits/std_vector.h:62,
                 from /usr/local/include/vector:31,
                 from table.h:10,
                 from table.cpp:1:
/usr/local/include/bits/stringfwd.h:39:28: bits/c++config.h: Error 0
In file included from /usr/local/include/bits/std_iosfwd.h:41,
                 from /usr/local/include/bits/stl_algobase.h:77,
                 from /usr/local/include/bits/std_vector.h:62,
                 from /usr/local/include/vector:31,
                 from table.h:10,
                 from table.cpp:1:
/usr/local/include/bits/fpos.h:39:24: bits/c++io.h: A file or directory in
the path name does not exist.
...

i looked for the files:

:/usr> find . -name c++*.h 2>/dev/null     
./local/include/powerpc-ibm-aix4.3.3.0/bits/c++config.h
./local/include/powerpc-ibm-aix4.3.3.0/bits/c++io.h
./local/include/powerpc-ibm-aix4.3.3.0/bits/c++locale.h

is that installation correct? 
what have i to do that the files from '/usr/local/include/bits' find the
'c++*.h'-files?
thanks for help

johannes




More information about the Gcc-help mailing list