Problem compiling gcc 3.0.1 on solaris 8

Schwartz Jr., William H. SchwaWH@nsc-msg01.network.com
Fri Sep 7 14:17:00 GMT 2001


I downloaded the prebuilt package of gcc 3.0.1 from www.sunfreeware.com and
isntalled that.  Then using that compiler I tried to build gcc 3.0.1 again
(need a seperate copy in a different location).

First I ran configure with the following.
./configure --with-as=/usr/local/bin/as --with-ld=/usr/local/bin/ld
--enable-libgcj --prefix=/nspdev

then "make -j 4 bootstrap"  (my compile machine is a quad processor
Ultrasparc)

after about 20 minutes I get:

.
.
 (several of these file exists lines..)
ln: cannot create ./valarray_array.tcc: File exists
ln: cannot create ./valarray_meta.h: File exists
make[4]: Leaving directory
`/home/anubis36/schwawh/SOLARIS_STUFF/gcc-3.0.1/sparc-sun-solaris2.8/libstdc
++-v
3/include'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
`/home/anubis36/schwawh/SOLARIS_STUFF/gcc-3.0.1/sparc-sun-solaris2.8/libstdc
++-v
3'
make[2]: *** [all-recursive-am] Error 2
make[2]: Leaving directory
`/home/anubis36/schwawh/SOLARIS_STUFF/gcc-3.0.1/sparc-sun-solaris2.8/libstdc
++-v
3'
make[1]: *** [all-target-libstdc++-v3] Error 2
make[1]: Leaving directory
`/home/anubis36/schwawh/SOLARIS_STUFF/gcc-3.0.1'
make: *** [bootstrap] Error 2

Is there some magic trick to compiling this?

thanks,
Bill



More information about the Gcc-help mailing list