GNU C++ for Linux

llewelly@edevnull.com llewelly@edevnull.com
Sat Sep 23 15:45:00 GMT 2000


"Dagmar Iber" <iber_dagmar@hotmail.com> writes:

> Dear All,
> 
> I have tried the whole week-end to install the GNU C++ compiler but I
> not manage. Whenever I wanted to compile my small program, the
> missing a package/library(?).

What small program did you try to compile? When reporting a problem,
  you must give an example sufficient to reproduce your problem.

[snip]
> Given that no end of that game was in sight, I have abandonned searching for
> these files in the internet and I have tried to install from another CD -
> same problem remained.
> 
> Last I tried installation from the internet

I have no idea what you mean by 'installation from the internet'.

General installation instructions for gcc  can be found at
  http://gcc.gnu.org/install/index.html

but I suggest you get a binary package from the makers of your linux
  distro. For example, if you are using Mandrake, look on the Mandrake
  install CD for a binary rpm of gcc - similarily for redhat, etc.

> but also this has not helped -
> possibly because I was not able to copy the foulder to the right location. I
> am a bloody beginner (I have Linux for four days now...) but it seems to me
> that the GNU compiler is looked for in /usr/include.

Not exactly. /usr/include is where C header files are traditionally
  stored. They are used by gcc (or any other C compiler), but most of
  them are not a part of gcc.

By default, gcc (and g++, etc) is installed under /usr/local, which
  means the executables (these arethe actual programs named 'gcc',
  'g++', etc) are in /usr/local/bin, and the libs in
  /usr/local/lib .

However, many Linux distrubutions come with gcc installed under /usr,
  which means the executables will be installed under /usr/bin, libs
  in /usr/lib, etc.

> There the two old
> versions of G++ are located.

If, by this, you are refering to:

  /usr/include/g++-2
  /usr/include/g++-3

then it is likely that gcc is already installed on your system, as
  these directories contian header files that are a part of the gcc's
  C++ libraries. (However, they are not 'two old version of g++'; they
  header files used by g++; g++ itself would likely be in /usr/bin)

Type 'g++ -v' at a command prompt, like this:

  $g++ -v

(Note: the '$' is used to represent the prompt; do not type it, and do
  not worry if your prompt looks different.)

> Linux does not allow me to move the folder from
> the internet into this directory (also not as a root user).
> 
> What can I do? Can anyone instruct me how to make the compiler work?

Try reading http://gcc.gnu.org/onlinedocs/gcc_toc.html for a while.

More importantly, find a good book on unix basics - say _Unix In A
  Nutshell_. If you are accostumed to usenet, try asking questions in
  comp.os.linux 


More information about the Gcc-help mailing list