gcc 2.95.2 32/64 bit compilation

Stefan Thiede Stefan.Thiede@sv.sc.philips.com
Tue Sep 19 09:51:00 GMT 2000


Hi Brett,

I've tried to get a 64 bit gcc version for Solaris 2.7 and
HP-UX 11 for the last 2 weeks and was told to use the latest
and greatest snapshots.

I've tried egcs-20000904 and binutils-000915 and couldn't get
it to work. The binutils snapshot has configure problems.
You need to use CVS and check out "ltcf-c.sh", it's
not in the snapshots.

Once past that, I get binutils and gcc compiled on Solaris,
but the gcc -m64 test.c  a.out program gives me a "Killed"
message if I want to execute it. gcc test.c works and reports
4 (bytes for the pointersize)

On HP-UX I couldn't get the binutils to compile.

I'm more then interested in feedback whether anybody get's it
to work on both platforms.

Best Regards

Stefan


#include <stdio.h>
#include <stdlib.h>

int main( int argc, char **argv )
{
  long *pint;
  printf("%d\n", sizeof(pint));
}

-------------------------------------------------------------------
Stefan Thiede              Tel:   +1 (408) 991-5619
Philips Semiconductors     Fax:   +1 (408) 991-5589
811 E. Arques Avenue
M/S 42, P.O. Box 3409     mailto: Stefan.Thiede@sv.sc.philips.com
Sunnyvale, CA 94048-3409  seri  :        thiede@usmtvsc1


More information about the Gcc-help mailing list